撸linux


wordpress网站底部jquery脚本无法使用的解决方法

wordpress网站底部的jquery脚本无法使用,跟wordpress的复杂机制没有关系。如果发生这种问题,那么可以肯定的是你的模板里面包含有多个js脚本,其中另一个js脚本一定使用了$这个符号,跟jquery库冲突。要想让这多个javascript脚本共存的方法就是将jQuery脚本里的$替换成jQuery。在这里一定要注意:jQuery不等于jquery,中间的Q一定要大写,否则无效,如下所示:

jQuery(function() {
    jQuery(".list-recent-comments").width(100);
});

再次重复一遍,$替换成jQuery,而不是jquery,可以解决标题中所说的问题。

相关博文



发表评论

电子邮件地址不会被公开。