撸linux


manjaro运行virtualbox提示Cannot mix incompatible Qt library (version 0x50700) with this library (version 0x50800)

系统版本

manjaro linux 2016.10

发生时间

2017.03.11 局部升级kernel、virtualbox、qt5之后

故障描述

虽然qt5已经升级到qt5.8,问题依然没有解决。很多软件都无法使用。

解决方法

执行yaourt -Syu命令全面升级

撸后感言

linux上软件包依赖关系就是个大坑。一旦你更新1个软件,不全部滚动升级就可能有无穷的故障出现。比如说更新了linux-kernel之后virtualbox就要更新,virtualbox要更新的话qt5又要更新,qt5更新的话harfbuzz什么的也要更新,最后忍无可忍,直到运行yaourt -Syu全面升级,故障才会消停。

相关博文



发表评论

电子邮件地址不会被公开。