撸linux


Archlinux安装google-chrome发生PGP密钥丢失错误问题的解决过程

我的Archlinux(2014.09)系统默认安装了chromium。但是这个chromium真操蛋,无论我怎么折腾配置flashplayer插件,它就愣是无法播放flash。于是下定决心安装chrome。然而运行pacman -S google-chrome安装的时候又发生PGP密钥丢失的错误(如下图所示)。

灰心了两次之后突然灵光一闪,在/var/cache/pacman/pkg文件夹里找到了google-chrome软件包,用file-roller直接打开它,然后将里面的文件直接提取到系统/根目录,最后运行google-chrome-stable,哈哈,搞定!上图!

(左边的chromium不能播放flash,右边的chrome能播放flash。)

经验:archlinux安装软件发现gpg错误时,从缓存里找到源码包直接提取到系统根目录,不失为一种解决问题的好方法。

相关博文



以下是网友的4条评论,您赞同吗?

  1. 匿名
    2015-10-4 0:28

    其实不用这么麻烦,只要把pacman.conf里源的等级改成Never就行了

  2. maijver
    2014-10-8 19:47

    其实chromium要想播放flash,
    只需要 yaourt chromium-pepper-flash

    • 小撸
      2014-10-9 11:28

      哦?这个一定有用。谢了。请常来逛。

      • 匿名
        2015-5-1 22:49

        aur里的chrome还是可以的!

发表评论

电子邮件地址不会被公开。