撸Linux


Manjaro/Archlinux切换fcitx为ibus输入法

用了好久的fcitx输入法,今天切换为ibus输入法遇到了麻烦。后来发现其实挺简单的,步骤跟我4年前写的某篇博文一样。

第1步,要保证桌面启动的时候启动ibus-daemon。方法是在/etc/xdg/autostart(或~/.config/autostart)文件夹里建立一个可执行的ibus.desktop文件,内容如下:

[Desktop Entry]
Exec=ibus-daemon -xdr
GenericName=IBus
Name[zh_CN]=IBus
Name=IBus
Name[en_US]=IBus
StartupNotify=true
Terminal=false
Type=Application

第1.1步,在/etc/xdg/autostart(或~/.config/autostart)文件夹里打开终端,执行chmod 755 ibus.desktop命令使ibus.desktop可执行。

第1.2步,如果之前安装了fcitx输入法,它会自动在/etc/xdg/autostart建立启动项,要删除之,如果~/.config/autostart也有,也要删除之。建议在删除之前压缩打包。

第2步,要保证ibus跟GTK、QT等应用融合。方法是在/etc/profile(或~/.xprofile)结尾处加入以下内容:

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus

最后,注销桌面或重启系统。

后面的话:

ArchWiki上的ibus手册都已经过时了,会害人的。还有在运行ibus-setup命令的时候提示在~/.bashrc里添加export GTK_IM_MODULE=ibus
之类的字样,对使用了显示管理器的用户也是无效的,只有添加到~/.xprofile或/etc/profile里才是最好的。

本方法也可适用于ibus切换为fcitx。

相关博文



以下是网友的4条评论,您赞同吗?

  1. 2019-3-14 10:16

    福建省厦门市某Linux用户觉得这篇文章很有帮助。

  2. keppel
    2019-1-29 18:06

    博主,关注你的网站很久了, 有两个关于manjaro的相关问题请教你一下:
    1. manjaro上面是不是已经不能安装mongodb数据库了, 我装了最新版本的manjaro, 软件库里面找不到mongodb的安装包, 官网也没有了;
    2. manjaro上面想装指定老版本的软件有什么办法吗? 好比说mysql现在是8, 我想装5的

    谢谢

    • 小撸
      2019-1-29 19:00

      1.没有相关经验
      2.装xampp,或者直接找官方网站比较老的xampp.run安装程序安装,我就一直用这个,MySQL版本5

  3. v21cesc
    2018-12-27 10:56

    这一点新版fedora就有优势了,ibus和fcitx可以无缝共存

发表评论

电子邮件地址不会被公开。