撸linux


sublime 3使用phpfmt美化/格式化php代码(xp下失败)

经由github开源协作出来的软件模块、插件,对程序员来说真的有吸引力,github的(一站式、点赞、开放式修改)开源模式让程序员有了一种家的感觉,无论对用户还是创作者,都有挡不住的魔力。与github相比,这几天我一直打开看https://www.editplus.com/html.html这个页面,这是editPlus的用户上传的插件工具页面,比起github就差多了。这个页面给人的第一感觉就是格局太小、没有人气、开放性差、活力不足。

说上面这些,其实就想表达一个意思,sublime因为在开源社区有了充满新鲜活力的支持,它才会比老牌的、商业的软件强大得多。在这之前,我一直犹豫用DW、gvim、EditPlus、phpDesigner,还是用sublime呢?今天终于确定了一个答案:只用sublime即可。

sublime 3使用phpfmt美化/格式化php代码步骤:

1,先到https://github.com/phpfmt/sublime-phpfmt点击Download ZIP按钮下载包

2,解压包到C:\Program Files\Sublime Text 3\Data\Packages\ (根据自己sublime安装情况改变路径)

3,作者提醒,这个插件必须有php 5.6以上版本才能支持,推荐下载standalone的php什么的。我是弄了一个上午死活没有搞定这个standalone的php。而且我一直用的是easyphp,但easyphp连官方网站没有这么高版本的php,怎么办呢?经过我的折腾,最终只有一个方案:放弃easyphp,切换到强大的xampp!可以到

http://sourceforge.net/projects/xampp/files/XAMPP%20Windows/5.6.15/ 下载高版本php的xampp测试服务器,然后折腾之!我选择的是xampp-portable-win32-5.6.15-1-VC11.7z

注意:xp下只能使用x86 32位版本。如果要用xampp,就得先退出easyphp服务器。

4,修改C:\Program Files\Sublime Text 3\Data\Packages\Sublime-phpfmt\phpfmt.sublime-settings文件,将// "php_bin":"/usr/local/bin/php"修改为

"php_bin":"你的xampp的php.exe路径"

5,使用方法ctrl+shift+P快捷键调出输入窗口,输入phpfmt,有一些选项可供选择。或者直接按ctrl+F11马上格式化。

=====================分割线======================

我的系统是xp,运行xampp的apche出现Return code: 0的错误,运行httpd.exe出现“httpd.exe 不是有效的 Win32应用程序”的错误提示,php也是“php.exe is not a valid Win32 application”,Perhapas you have to install the Microsoft Visual C++ 2008 Redistributable package。后来看这里http://www.hack80.com/thread-25026-1-1.html得知xp里不能装vc11版本的xampp

PHP 5.4 series will be the last versions to support Windows XP and Windows 2003. We will not provide binary packages for these Windows versions anymore after PHP 5.4.

xp下安装php5.6从而使用phpfmt,看来是彻底没办法了!唉,白白浪费半天工作时间!

相关博文



1 comment for

  1. 2016-9-25 17:03

    这个格式化的也不是非常满意,而且设置都要通过代码,有点不习惯。

发表评论

电子邮件地址不会被公开。